import re
regex = re.compile(r"((?:\|\s*|^)\d+)[ .](\d+)")
test_str = ("|12 546,123 | AROME 53.213 | 52 321,15\n"
"| 2.546,123 | AROME 53 213 |152.321,15")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)