package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:\|\s*|^)\d+)[ .](\d+)`)
var str = `|12 546,123 | AROME 53.213 | 52 321,15
| 2.546,123 | AROME 53 213 |152.321,15`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}