# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*("{0,1})(;|\n){1}/\1\2/g;t' <<< "\"this \"; is ; a test; obviously
I need ;to escape ;\"trailing whitespace \";\"from a CSV \"
Hope doing ;\"this through \"; a regex replace
in python ;\"will be fast \";for huge files "