$re = '/\s*("{0,1})(;|\n){1}/';
$str = '"this "; is ; a test; obviously
I need ;to escape ;"trailing whitespace ";"from a CSV "
Hope doing ;"this through "; a regex replace
in python ;"will be fast ";for huge files ';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;