import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(\"{0,1})(;|\\n){1}";
final String string = "\"this \"; is ; a test; obviously \n"
+ "I need ;to escape ;\"trailing whitespace \";\"from a CSV \"\n"
+ "Hope doing ;\"this through \"; a regex replace\n"
+ "in python ;\"will be fast \";for huge files ";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}