// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\s*("{0,1})(;|\n){1}"#).unwrap();
let string = "\"this \"; is ; a test; obviously
I need ;to escape ;\"trailing whitespace \";\"from a CSV \"
Hope doing ;\"this through \"; a regex replace
in python ;\"will be fast \";for huge files ";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}