use strict;
my $str = '"this "; is ; a test; obviously
I need ;to escape ;"trailing whitespace ";"from a CSV "
Hope doing ;"this through "; a regex replace
in python ;"will be fast ";for huge files ';
my $regex = qr/\s*("{0,1})(;|\n){1}/p;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";