using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(""{0,1})(;|\n){1}";
string substitution = @"\1\2";
string input = @"""this ""; is ; a test; obviously
I need ;to escape ;""trailing whitespace "";""from a CSV ""
Hope doing ;""this through ""; a regex replace
in python ;""will be fast "";for huge files ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}