import re
regex = re.compile(r"\s*(\"{0,1})(;|\n){1}")
test_str = ("\"this \"; is ; a test; obviously \n"
"I need ;to escape ;\"trailing whitespace \";\"from a CSV \"\n"
"Hope doing ;\"this through \"; a regex replace\n"
"in python ;\"will be fast \";for huge files ")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)