# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$VAR(?=[\s\$]|$)/success/g;t' <<< "$VAR VAR $$VAR $VAR1 $VAR1$VAR$VAR2 $VAR"