import Foundation
let pattern = #"\$VAR(?=[\s\$]|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"$VAR VAR $$VAR $VAR1 $VAR1$VAR$VAR2 $VAR"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"success"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)