re = /\$VAR(?=[\s\$]|$)/
str = '$VAR VAR $$VAR $VAR1 $VAR1$VAR$VAR2 $VAR'
subst = 'success'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result