$re = '/\$VAR(?=[\s\$]|$)/';
$str = '$VAR VAR $$VAR $VAR1 $VAR1$VAR$VAR2 $VAR';
$subst = "success";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;