use strict;
my $str = '$VAR VAR $$VAR $VAR1 $VAR1$VAR$VAR2 $VAR';
my $regex = qr/\$VAR(?=[\s\$]|$)/p;
my $subst = 'success';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";