using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$VAR(?=[\s\$]|$)";
string substitution = @"success";
string input = @"$VAR VAR $$VAR $VAR1 $VAR1$VAR$VAR2 $VAR";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}