const regex = /\$VAR(?=[\s\$]|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$VAR(?=[\\s\\$]|$)', 'g')
const str = `\$VAR VAR \$\$VAR \$VAR1 \$VAR1\$VAR\$VAR2 \$VAR`;
const subst = `success`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);