#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$VAR(?=[\s\$]|$)"
Local $sString = "$VAR VAR $$VAR $VAR1 $VAR1$VAR$VAR2 $VAR"
Local $sSubst = "success"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)