import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$VAR(?=[\\s\\$]|$)";
final String string = "$VAR VAR $$VAR $VAR1 $VAR1$VAR$VAR2 $VAR";
final String subst = "success";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}