#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\+39([0-9]{9,15})"
Local $sString = "+39932312345234124" & @CRLF & _
"+33920370024" & @CRLF & _
"3920370024" & @CRLF & _
"+39392037002/^123456$/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/\(?([+39])\)?([ .-]?)([0-9]{3})\2([0-9]{10,15})/" & @CRLF & _
"(^\+39$)([ .-]?)([0-9]{3})\2([0-9]{9,15})"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")