# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\+39([0-9]{9,15})"
test_str = ("+39932312345234124\n"
"+33920370024\n"
"3920370024\n"
"+39392037002/^123456$/\n\n\n"
"/\\(?([+39])\\)?([ .-]?)([0-9]{3})\\2([0-9]{10,15})/\n"
"(^\\+39$)([ .-]?)([0-9]{3})\\2([0-9]{9,15})")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.