re = /^\+39([0-9]{9,15})/
str = '+39932312345234124
+33920370024
3920370024
+39392037002/^123456$/
/\\(?([+39])\\)?([ .-]?)([0-9]{3})\\2([0-9]{10,15})/
(^\\+39$)([ .-]?)([0-9]{3})\\2([0-9]{9,15})'
# Print the match result
str.match(re) do |match|
puts match.to_s
end