using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+39([0-9]{9,15})";
string input = @"+39932312345234124
+33920370024
3920370024
+39392037002/^123456$/
/\(?([+39])\)?([ .-]?)([0-9]{3})\2([0-9]{10,15})/
(^\+39$)([ .-]?)([0-9]{3})\2([0-9]{9,15})";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}