// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\+39([0-9]{9,15})").unwrap();
let string = "+39932312345234124
+33920370024
3920370024
+39392037002/^123456$/
/\\(?([+39])\\)?([ .-]?)([0-9]{3})\\2([0-9]{10,15})/
(^\\+39$)([ .-]?)([0-9]{3})\\2([0-9]{9,15})";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}