import Foundation
let pattern = #"^\+39([0-9]{9,15})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
+39932312345234124
+33920370024
3920370024
+39392037002/^123456$/
/\(?([+39])\)?([ .-]?)([0-9]{3})\2([0-9]{10,15})/
(^\+39$)([ .-]?)([0-9]{3})\2([0-9]{9,15})
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}