use strict;
my $str = '+39932312345234124
+33920370024
3920370024
+39392037002/^123456$/
/\\(?([+39])\\)?([ .-]?)([0-9]{3})\\2([0-9]{10,15})/
(^\\+39$)([ .-]?)([0-9]{3})\\2([0-9]{9,15})';
my $regex = qr/^\+39([0-9]{9,15})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}