const regex = /^\+39([0-9]{9,15})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+39([0-9]{9,15})', '')
const str = `+39932312345234124
+33920370024
3920370024
+39392037002/^123456\$/
/\\(?([+39])\\)?([ .-]?)([0-9]{3})\\2([0-9]{10,15})/
(^\\+39\$)([ .-]?)([0-9]{3})\\2([0-9]{9,15})`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}