# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$(?P<ItemCost>\d{1,3}(?:,\d{3})*(?:\.\d{2}))/$1/gi;t' <<< "$123,456,789.00"