#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\$(?P<ItemCost>\d{1,3}(?:,\d{3})*(?:\.\d{2}))"
Local $sString = "$123,456,789.00"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)