using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$(?P<ItemCost>\d{1,3}(?:,\d{3})*(?:\.\d{2}))";
string substitution = @"$1";
string input = @"$123,456,789.00";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}