// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\$(?P<ItemCost>\d{1,3}(?:,\d{3})*(?:\.\d{2}))").unwrap();
let string = "$123,456,789.00";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}