use strict;
my $str = '$123,456,789.00';
my $regex = qr/\$(?P<ItemCost>\d{1,3}(?:,\d{3})*(?:\.\d{2}))/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";