$re = '/\$(?P<ItemCost>\d{1,3}(?:,\d{3})*(?:\.\d{2}))/i';
$str = '$123,456,789.00';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;