re = /\$(?P<ItemCost>\d{1,3}(?:,\d{3})*(?:\.\d{2}))/i
str = '$123,456,789.00'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result