const regex = /\$(?P<ItemCost>\d{1,3}(?:,\d{3})*(?:\.\d{2}))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$(?P<ItemCost>\\d{1,3}(?:,\\d{3})*(?:\\.\\d{2}))', 'gi')
const str = `\$123,456,789.00`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);