import Foundation
let pattern = #"\$(?P<ItemCost>\d{1,3}(?:,\d{3})*(?:\.\d{2}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"$123,456,789.00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)