package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\sMission world\:\s*(?P<game_map>.*)`)
var str = `2022/11/13, 11:52:47 Mission world: cam_lao_nam
2022/11/18, 10:59:17 Mission world: vt7
2022/10/31, 09:46:13 Mission world: Altis
2022/12/04, 13:23:30 Mission world: vn_khe_sanh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}