import Foundation
let pattern = #"\sMission world\:\s*(?P<game_map>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2022/11/13, 11:52:47 Mission world: cam_lao_nam
2022/11/18, 10:59:17 Mission world: vt7
2022/10/31, 09:46:13 Mission world: Altis
2022/12/04, 13:23:30 Mission world: vn_khe_sanh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)