re = /\sMission world\:\s*(?P<game_map>.*)/m
str = '2022/11/13, 11:52:47 Mission world: cam_lao_nam
2022/11/18, 10:59:17 Mission world: vt7
2022/10/31, 09:46:13 Mission world: Altis
2022/12/04, 13:23:30 Mission world: vn_khe_sanh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end