const regex = new RegExp('\\sMission world\\:\\s*(?P<game_map>.*)', 'gm')
const str = `2022/11/13, 11:52:47 Mission world: cam_lao_nam
2022/11/18, 10:59:17 Mission world: vt7
2022/10/31, 09:46:13 Mission world: Altis
2022/12/04, 13:23:30 Mission world: vn_khe_sanh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}