import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\sMission world\\:\\s*(?P<game_map>.*)";
final String string = "2022/11/13, 11:52:47 Mission world: cam_lao_nam\n\n"
+ "2022/11/18, 10:59:17 Mission world: vt7\n\n"
+ "2022/10/31, 09:46:13 Mission world: Altis\n\n"
+ "2022/12/04, 13:23:30 Mission world: vn_khe_sanh";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}