use strict;
my $str = '2022/11/13, 11:52:47 Mission world: cam_lao_nam
2022/11/18, 10:59:17 Mission world: vt7
2022/10/31, 09:46:13 Mission world: Altis
2022/12/04, 13:23:30 Mission world: vn_khe_sanh';
my $regex = qr/\sMission world\:\s*(?P<game_map>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}