// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\sMission world\:\s*(?P<game_map>.*)").unwrap();
let string = "2022/11/13, 11:52:47 Mission world: cam_lao_nam
2022/11/18, 10:59:17 Mission world: vt7
2022/10/31, 09:46:13 Mission world: Altis
2022/12/04, 13:23:30 Mission world: vn_khe_sanh";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}