#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)`{3}(`*[^`\n]+`*)`{3}"
Local $sString = "```test```"
Local $sSubst = "<pre>$1</pre>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)