const regex = /`{3}(`*[^`\n]+`*)`{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('`{3}(`*[^`\\n]+`*)`{3}', 'gm')
const str = `\`\`\`test\`\`\``;
const subst = `<pre>$1</pre>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);