import re
regex = re.compile(r"`{3}(`*[^`\n]+`*)`{3}", flags=re.MULTILINE)
test_str = "```test```"
subst = "<pre>$1</pre>"
result = regex.sub(subst, test_str)
if result:
print(result)