import Foundation
let pattern = #"`{3}(`*[^`\n]+`*)`{3}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"```test```"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<pre>$1</pre>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)