$re = '/`{3}(`*[^`\n]+`*)`{3}/m';
$str = '```test```';
$subst = "<pre>$1</pre>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;