use strict;
my $str = '```test```';
my $regex = qr/`{3}(`*[^`\n]+`*)`{3}/mp;
my $subst = '<pre>$1</pre>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";