using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"`{3}(`*[^`\n]+`*)`{3}";
string substitution = @"<pre>$1</pre>";
string input = @"```test```";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}