re = /`{3}(`*[^`\n]+`*)`{3}/m
str = '```test```'
subst = '<pre>$1</pre>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result